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Procedimentos para correção geométrica de 

imagens de satélite 

 
 

Introdução 

A correção geométrica envolve a modelagem da relação entre a imagem e o 

sistema de coordenadas da superfície da terra. Os modelos de correção 

geométrica podem ser divididos em modelos polinomiais, ou registro, e modelos 

fotogramétricos. Os primeiros usam funções polinomiais determinadas usando 

pontos de controle, de correção independente, em que as fontes de distorção 

são analisadas e modeladas de forma independente. Os modelos 

fotogramétricos usam informações orbitais do satélite e parâmetros do sensor 

para relacionar um ponto da imagem ao seu correspondente no terreno 

(D’ALGE, 2007). A correção geométrica usando modelos polinomiais tem a 

vantagem de ser de simples execução e não requerer conhecimento de 

parâmetros orbitais e do sistema sensor.  

Essa correção é relevante porque as imagens obtidas por meio de satélites no 

nível orbital apresentam distorções. Essas distorções podem ser inerentes à 

plataforma (velocidade, altitude e posição), ao instrumento, ao tipo de sensor 

(varredura mecânica ou eletrônica) e ao modelo da Terra (rotação, esfericidade, 

relevo, etc.). Também é importante quando desejamos criar uma relação com 

uma base de dados de um sistema de informações geográficas (SIG), pois para 

que novos dados sejam inseridos no SIG é necessário que eles tenham correta 

referência espacial. 

Esta Circular Técnica visa estabelecer um protocolo de correção geométrica de 

imagens de satélite. Dessa forma, no âmbito das atividades de 

geoprocessamento em projetos internos da Embrapa Monitoramento por 

Satélite, tais como AgSpec, Aftosa, GeoRastro e GeoDegrade1, este documento 

apresenta as etapas do processo de correção geométrica feito utilizando três 

aplicativos, ArcMap, ENVI e ERDAS, além da aquisição automática de pontos de 

controle no aplicativo Regeemy. 

Material e Métodos 

As etapas serão demonstradas nos três aplicativos diferentes, porém cabe 

ressaltar que os passos básicos são: 1) aquisição e empilhamento das bandas 

multiespectrais; 2) correção do hemisfério das imagens GeoCover; 3) coleta de 

pontos de controle; e 4) salvamento da imagem registrada. 

 

1 Disponível em: <http://www.cnpm.embrapa.br/projetos/projetos.php>. 
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Aquisição da base de dados 

Imagem referência 

Para realizar a correção geométrica é necessária uma imagem previamente registrada, chamada 

também imagem de referência. No catálogo do Global Land Cover Facility2 é possível adquirir imagens 

de toda a superfície do globo previamente corrigidas. Devem ser seguidas as seguintes etapas: 

 Selecione ESDI (Figura 1). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 1. Interface do 

catálogo de imagens do 

Global Land Cover Facility. 

 

Selecione Map Search (Figura 2). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 2. Seleção da 

imagem de referência no 

catálogo de imagens do 

Global  Land  

Cover Facility. 

 

 

 
2 Disponível em: <http://glcf.umiacs.umd.edu/>. 
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Marque a opção ETM+ no canto superior esquerdo da janela, em Landsat Imagery.  Escolha a órbita 

(Path) e o ponto (Row). O exemplo mostra a escolha pela imagem de órbita-ponto 221-71. Por fim, 

clique em Preview and Download (Figura 3). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 3. Interface do 

catálogo de imagens do 

Global Land Cover Facility 

para seleção da órbita-ponto 

da imagem de referência. 

 Escolha a imagem do tipo Ortho, GLS2005 e clique em Download (Figura 4). 

Figura 4. Interface 

do catálogo de 

imagens do Global 

Land Cover Facility 

para seleção do tipo 

da imagem de 

referência, neste 

exemplo Ortho, 

GLS2005. 

 

Escolha as bandas da imagem com final BXX.TIF.gz, por exemplo B10.TIF.gz (Figura 5). 

 

 

 

 

 

 

 

 

 

 

Figura 5. Interface do catálogo de imagens 

do Global Land Cover Facility para seleção as 

andas multiespectrais da imagem de  

referência. 
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Imagem a ser corrigida 

A segunda etapa consiste na aquisição da imagem a ser corrigida. No catálogo de imagens do Instituto 

Nacional de Pesquisas Espaciais (INPE)3, é possível obter, entre outros, cenas dos satélites Landsat e 

Resourcesat-1. Para isso, devem ser seguidos os passos abaixo. 

Escolha o satélite Landsat-5, ou outro satélite de interesse, a data e preencha a órbita-ponto. O 

exemplo mostra a escolha da imagem de órbita-ponto 221-71. É fundamental que a órbita-ponto da 

imagem de referência e da imagem que será corrigida sejam iguais (Figura 6). 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 6. Interface do catálogo de 

imagens do Instituto Nacional de 

Pesquisas Espaciais para seleção 

da imagem a ser registrada. 

 
Figura 7. Interface do catálogo de imagens do Instituto Nacional de Pesquisas Espaciais para  

seleção da imagem registrada a ser adquirida. 

 

 

Correção geométrica no aplicativo ArcMap 

No aplicativo ArcMap, a correção geométrica deve ser realizada da seguinte forma: 

Crie duas pastas, base_registrada e para_registro. Coloque as bandas das imagens baixadas do 

catálogo GLCF (L71221071_07120060531_B10.TIF) na pasta base_registrada e as bandas das 

imagens do catálogo do INPE (LANDSAT_5_TM_20100923_221_071_L2_BAND1.TIF) na pasta 

para_registro. 

 

 

 

3 Disponível em: <http://www.dgi.inpe.br/CDSR/>. 
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Descompacte as bandas das imagens nas pastas correspondentes (Figura 8). 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 8. Descompactação das bandas 

multiespectrais adquiridas. 

 

 

No ArcMap, clique em Arctoolbox ( ). Clique em Data Management Tools > Raster > 

RasterProcessing > Composite. Selecione as bandas descompactadas na pasta para_registro e salve o 

novo arquivo. As bandas serão empilhadas em um único arquivo. O mesmo procedimento deve ser 

adotado para as bandas extraídas na pasta base_registrada (Figura 9). É válido ressaltar que a ordem 

do empilhamento é importante, pois o ArcMap não armazena a ordem em que as bandas foram 

empilhadas. Além disso, devem ser consideradas as bandas de 1 a 5 e a banda 7, pois elas têm a 

mesma resolução espacial (30 m). 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 9. Interface do aplicativo ArcMap da 

ferramenta Composite Bands. 

 

 

As duas imagens automaticamente aparecerão em Table of Contents, no lado esquerdo da tela do 

aplicativo ArcMap (Figura 10).  
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Figura 10. Interface do aplicativo ArcMap após o empilhamento das bandas das imagens de 

referência e a ser corrigida. 

 

 

A imagem descompactada na pasta base_registrada (catálogo GLCF) deve ser reprojetada para a 

mesma projeção da imagem na pasta para_registro (catálogo INPE) para que a correção geométrica seja 

realizada no aplicativo ArcMap. Para executar a reprojeção da imagem com o Arctoobox ( ) clique em 

Data Management Tools > Projections and Transformations > Raster > Project Raster (Figura 11). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 11. Interface da ferramenta Project Raster 

do aplicativo ArcMap. 

 

As imagens do catálogo GLCF, imagem de referência, são disponibilizadas com a zona UTM correta, 

porém com hemisfério errado (norte). É importante que as imagens fiquem com a mesma projeção 

cartográfica e o mesmo hemisfério. Clique no botão . Na janela Spatial Reference Properties, clique 

em Import e indique a imagem na pasta para_registro (do catálogo INPE) (Figura 12). 
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Figura 12. Interface do aplicativo ArcMap para reprojeção da imagem de referência. 

 

Clique em OK e a imagem será reprojetada.  

Reinicie o aplicativo ArcMap e abra a imagem da pasta base_registrada (do catálogo GLCF), 

reprojetada, e a imagem da pasta para_registro (do catálogo INPE). 

Habilite a ferramenta Georeferencing, clique em Georeferencing e desabilite Auto Adjust. Na opção 

Layer, escolha a imagem da pasta para_registro (Figura 13). 

Figura 13. Barra de ferramentas da extensão 

Georeferencing. 

 

A seleção dos pontos de controle deve ser realizada da seguinte forma (Figura 14): 

a) Escolha um local (cruzamento de estradas, curso d’água, etc.) na imagem da pasta para_registro (do 

catálogo INPE) e clique no botão  para adicionar um ponto de controle na imagem. 

b) Encontre o mesmo local na imagem da pasta base_registrada (do catálogo GLCF) e adicione o ponto 

de controle. 

 
(a)                                                         (b) 

Figura 14. Visualização do deslocamento da imagem a ser corrigida (b) em relação à imagem de  

referência (a). 
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Distribua os pontos por toda a imagem e apague os que não ficaram bem ajustados. A opção  

permite verificar o erro RMS de cada ponto. O valor do erro RMS total não deve ser maior que 0,5, o 

que representa um erro de deslocamento de 0,5 pixel. 

Para aplicar a correção geométrica, clique em Georeferencing > Rectify. 

 

Correção geométrica no aplicativo ENVI 

A correção geométrica no aplicativo ENVI deve obedecer as seguintes etapas: 

Abra o programa ENVI e clique em Basic Tools > Layer Stacking > Import File > Open – New File e 

selecione as bandas da pasta base_registrada do catálogo GLCF (abra somente as bandas inseridas 

nesta pasta) e clique em OK (Figura 15). 

 

 

 

 

 

 

Figura 15. Seleção das bandas multiespectrais para  

empilhamento no aplicativo ENVI. 

 

 

Clique em Reorder Files, e coloque as bandas em ordem crescente (1 até 7, menos a banda 6, cuja 

resolução espacial é diferente da das bandas de 1 a 7) e clique em OK. A projeção deve ser mantida 

como UTM, o datum, WGS-84 e a zona deve ser alterada para sul (S). Em Output Result, selecione File 

e escolha a pasta base_registrada e o nome nome_satelite_sensor__orbita-ponto_ano_mes_dia_bandas_ 

base (exemplo: landsat5_tm_221-71_20060531_123457_base) (Figura 16). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 16. Ordenamento das bandas multiespectrais e 

reprojeção das imagens em ambiente ENVI. 
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Figura 17. Resultado do empilhamento  

das bandas em ambiente ENVI. 

 

 

Repita o mesmo processo para as bandas extraídas na pasta para_registro, do catálogo INPE. Em 

Output Result, selecione File e escolha a pasta para_registro e o nome nome_satelite_sensor__orbita-

ponto_ano_mes_dia_bandas_para_registro (exemplo: landsat5_tm_221-71_20060531_123457_ 

para_registro). 

Abra as duas imagens em janelas separadas e clique em Map > Registration > Select From GCPs: 

Image To Image. Na janela Image to Image Registration, escolha em Base Image o Display #1 (a 

imagem de referência deve estar aberta na janela 1) e em Warp Image o Display #2 (a imagem para 

registro deve estar aberta na janela 2) (Figura 18). 

 

 

 

 

Figura 18. Interface do aplicativo ENVI para 

indicação da imagem base e imagem de referência. 

 

Distribua os pontos (marque cerca de 30) por toda a imagem e apague os que apresentarem erros 

elevados. O valor do erro RMS não deve ser maior que 0,5. Na janela Ground Control Points Selection, 

clique em File > Save GCPs to ASCII e selecione nome_satelite_sensor_orbita-ponto_ano_mes_dia_ 

bandas_registrada. Em Options > Warp File, selecione a imagem que está sendo registrada 

(para_registro) e, em Output Result, selecione file e escolha a pasta para_registro e o nome 

nome_satelite_sensor__orbita-ponto_ano_mes_dia_bandas_registrada (exemplo: landsat5_tm_221-

71_20060531_123457_registrada) (Figura 19). 

 

 

 

 

Figura 19. Interface do aplicativo ENVI  

indicando o número total de pontos e o  

erro RMS. 
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Correção geométrica no aplicativo ERDAS Imagine 

A correção geométrica no aplicativo ERDAS Imagine deve ser realizada de acordo com as seguintes 

etapas: 

 

 

 

 

 

 

 

 

 

 

Figura 20. Interface do aplicativo ERDAS Imagine para seleção 

da imagem a ser trabalhada. 

 

 

 

 

 

 

 

 

 

Figura 21. Seleção das bandas multiespectrais para 

empilhamento no aplicativo ERDAS Imagine. 
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Na janela Layer Selection and Stacking, adicione os arquivos de cada uma das bandas clicando na seta 

para baixo no campo Input File e, em seguida, clicando no botão Add (Adicionar). Repita esta operação 

para todas as bandas, na ordem crescente, da banda 1 até a banda 7 (desconsidere a banda 6). A 

numeração das bandas no arquivo final segue a ordem em que as bandas são inseridas nesta etapa. 

Selecione o nome para o arquivo de saída no campo Output File e clique em OK (Figura 22). 

 

 

 

 

 

 

 

Figura 22. Ordenamento das bandas multiespectrais e 

reprojeção das imagens em ambiente ERDAS Imagine. 

 

Repita o procedimento de empilhamento de bandas com a imagem da pasta para_registro, adquirida do 

catálogo INPE. 

Para reprojetar a imagem no hemisfério norte, antes de iniciar a coleta de pontos de controle, tenha 

pelo menos uma imagem com bandas empilhadas em uma janela do aplicativo ERDAS Imagine. Clique 

na aba Raster > Multispectral e, em seguida, em Transform & Orthocorrect > Reproject. Neste caso, 

prossiga diretamente para o item 2.3.5 (Figura 23). 

 

 

 

 

 

 

 

 

Figura 23. Reprojeção de imagem 

no aplicativo ERDAS Imagine. 
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Selecione o arquivo nomeado como base_registrada como arquivo de entrada. O nome do arquivo de 

saída deverá terminar com o nome base_registrada_reprojetada. Mude a projeção de saída para a 

categoria UTM WGS 84 South e, no campo Projection, selecione a zona correspondente à da imagem. 

Em seguida, clique em OK (Figura 24). 

 
Figura 24. Interface da reprojeção de imagem no aplicativo ERDAS Imagine. 

 

Inicie a coleta de pontos de controle para executar a correção. Clique novamente na aba Raster > 

Multispectral e, em seguida, em Transform & Orthocorrect > Control Points (Figura 25). 

 
Figura 25. Interface do aplicativo ERDAS Imagine para seleção dos pontos de controle. 

Na janela Set Geometric Model selecione o modelo Polynomial. A seguir, indique, na janela GCP Tool 

Reference Setup, que os pontos de referência serão coletados de uma imagem. Clique em OK e 

selecione a imagem cujo nome termina com base_referenciada_reprojetada. Em seguida, a janela 

Reference Map Information será exibida indicando o sistema de coordenadas da imagem definida como 

referência. Concluído esse procedimento, é aberta a janela Multipoint Geometric Correction, onde serão 

coletados os pontos de controle. À esquerda fica a imagem de entrada, que será referenciada. À direita 

fica a imagem base. Cada uma delas é apresentada em três visões diferentes: 
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 Uma visão principal com a imagem na escala de 1:1 entre pixels da imagem e pixels da tela do 

computador; 

 Outra visão em que a imagem aparece inteira, para navegação (Overview); 

 E uma visão ampliada, para aumentar a precisão do ponto de controle que será coletado (Zoom 

View). 

Para mudar a composição RGB das bandas na janela Multipoint Geometric Correction, clique com o 

botão esquerdo do mouse sobre uma das janelas e selecione a opção Band Combinations. Selecione as 

bandas da composição nos campos à direita da janela Set Bands Combinations. Esta operação só altera 

a cor de uma janela de cada vez. Repita a operação para todas as janelas que achar necessário (Figura 

26). 

 

 

 

 

Figura 26. Seleção de bandas para 

composição RGB no aplicativo ERDAS 

Imagine. 

 

 

Para alterar a cor dos pontos e torná-los mais destacados na tela, clique com o botão direito do mouse 

nas duas colunas Color presentes na lista de pontos, na parte inferior da janela. Selecione uma cor que 

seja distinguível na composição RGB que estiver utilizando. No caso da composição das bandas 4-5-3, 

a cor amarela é uma boa opção (Figura 27). 

 
Figura 27. Alteração da cor dos pontos de controle no aplicativo ERDAS Imagine. 
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Para iniciar a coleta dos pontos, clique no botão  localizado na barra de menus. Em seguida, clique 

no ponto desejado em uma das imagens (de entrada ou de referência) utilizando preferencialmente o 

Zoom View. Clique novamente no botão  e clique no ponto correspondente ao primeiro ponto na 

outra imagem. Selecione cerca de 30 pontos e, em seguida, elimine os que apresentarem maior erro. 

Analise a tabela de erros, para verificar o posicionamento dos pontos que apresentarem os maiores 

erros. Se o posicionamento estiver errado ele pode ser eliminado. Porém, se estiver correto, é preciso 

avaliar o posicionamento dos outros pontos. Para aplicar a correção geométrica à imagem após coletar 

os pontos de controle necessários, clique no botão Display Resample Image Dialog ( ). Para averiguar 

o erro de cada ponto de controle, verifique o valor da coluna RMS Error na tabela dos pontos (Figura 

28). 

 

Figura 28. Coleta de pontos de controle no aplicativo ERDAS Imagine. 

Na janela Resample, selecione a pasta de destino e o nome do arquivo de saída, que deverá ter o nome 

satelite_sensor_orbita-ponto_ano_mes_dia_bandas_registrada (exemplo: landsat5_tm_221-

71_20060531_123457_registrada). Clique em OK. 

Aquisição automática de pontos de controle 

Nos exemplos demonstrados nos aplicativos ArcMap, ENVI e ERDAS Imagine, o usuário necessita 

extrair os pontos de controle de forma manual, ou seja, precisa indicar os pontos em ambas imagens. 

O programa Regeemy (FEDOROV et al., 2002) tem por finalidade a extração automática de pontos de 

controle em imagens de satélite. O aplicativo está disponível em http://regima.dpi.inpe.br/ 

download.html. Para a aquisição automática de pontos de controle não é necessário empilhar todas as 

bandas. O usuário deve escolher apenas uma banda e realizar o processo no aplicativo Regeemy. Cabe 

ressaltar que a imagem de referência deve ser reprojetada para o hemisfério sul antes da coleta dos 

pontos de controle. O Regeemy não permite realizar esta correção, que deve ser feita usando outro 

aplicativo, como o ArcMap, ENVI ou ERDAS Imagine. 
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Abra o aplicativo Regeemy e carregue, primeiro, a imagem de referência em Image 1 – Reference e, 

depois, a imagem a ser registrada em Image 2 - Sensed.  

 

 

 

 

 

 

 

 

 

 

Figura 29. Interface do aplicativo Regeemy 

para seleção de imagens. 

 

Para definir os parâmetros de aquisição de pontos de controle, clique na aba Register > Tie point 

acquisition. No campo Type, escolha Automatic default e, no campo Quality, escolha Exaggerated 

(512 pts). No campo Transformation, selecione Type: Affine. Selecione a aba Rectangles e clique no 

botão Select Rectangles (Figura 30). 

 

 

 

 

 

 

 

 

 

Figura 30. Interface do aplicativo Regeemy para 

definição dos parâmetros de aquisição dos pontos 

de controle. 
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Selecione o primeiro retângulo nas duas imagens das quais serão extraídos os pontos de controle. 

Observe que a mesma área deve ser marcada em ambas as imagens. Esse processo tem como objetivo 

calibrar o aplicativo, ajustando inicialmente as imagens. O desenho do retângulo faz o aplicativo buscar 

pontos de controle apenas na área delimitada. Para garantir a qualidade do registro, os retângulos não 

devem ultrapassar 1.000 linhas por 1.000 colunas, dado que pode ser observado na parte inferior 

direita das janelas que mostram as imagens. 

Clique em Auto Find Tie Points para buscar os pontos de controle no retângulo delimitado (Figura 31). 

 
Figura 31. Interface do aplicativo Regeemy para aquisição dos pontos de controle. 

 

 

O resultado da qualidade do processamento é monitorado na caixa de diálogo Log, que aparecerá logo 

após a primeira busca dos pontos. A qualidade dos pontos localizados pelo programa Regeemy pode 

ser A EXCELENTE FIT, A GOOD FIT ou A BAD FIT. Nos dois primeiros casos, considere os pontos 

fornecidos pelo programa. Caso a qualidade observada seja A BAD FIT, desconsidere os pontos e faça 

o processamento novamente (Figura 32). 

 

 

 

 

 

 

 

 

 

 

Figura 32. Interface do aplicativo Regeemy para  

controle de qualidade dos pontos adquiridos. 
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Após distribuir os pontos pela imagem, os que apresentarem maior erro RMS devem ser excluídos. É 

recomendável que o erro RMS total da imagem não seja superior a 0,5.  

A última etapa no aplicativo Regeemy é salvar os pontos no formato .pts (ENVI) na caixa de diálogo 

dos pontos localizados na imagem. Na tela Tie Points, selecione File > Save as (Figura 33). 

 

 

 

 

 

 

 

 

 

Figura 33. Visualização da tela Tie Points 

utilizada para exportar os pontos de controle 

adquiridos. 

 

Após a extração dos pontos, é possível carregá-los em outro aplicativo para fazer o registro. Esse 

processo será exemplificado no procedimento do aplicativo ENVI, onde primeiramente devem ser 

abertas as duas imagens, imagem de referência e registrada. 

Abra a ferramenta utilizada para o registro: Map > Registration > Select GCPs: Image to Image (etapa 

da Figura 17 deste documento). Selecione o arquivo de pontos salvos no aplicativo Regeemy clicando, 

para isso, em File > Restore GCPs from ASCII. Para salvar a imagem corrigida, repita a etapa seguinte 

(Figura 34). 

 

 

 

 

Figura 34. Interface do aplicativo ENVI para restaurar os 

pontos de controle adquiridos no aplicativo Reegemy. 
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Considerações finais 

A correção geométrica é uma etapa fundamental do pré-processamento das imagens de satélite. Ela 

permite a adequação da imagem a uma projeção específica, reduzindo o efeito de distorções 

geométricas e, por conseguinte, o desenvolvimento de pesquisas e produtos com maior acurácia. Os 

aplicativos utilizados nos procedimentos adotados atenderam as expectativas. O aplicativo Regeemy 

em particular mostrou ser de extrema importância, principalmente em projetos que necessitam de uma 

grande quantidade de imagens a serem registradas.  
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