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Apresentação

Esta apostila se destina ao treinamento de pesquisadores, analistas e estagiários

da Embrapa Solos, e também de seus parceiros, em ferramentas de Sistemas de

Informação Geográfica, no caso, utilizando o programa ArcGIS da ESRI.

O treinamento em ArcGis iniciou-se em 2006 e foi oferecido nos anos de 2007

e 2010, contando com a participação de funcionários da Embrapa Solos e de

parceiros de outras unidades da Embrapa, como Agrobiologia, Florestas, Meio

Ambiente e Meio Norte, além de pesquisadores, funcionários e estudantes da

Universidade Estadual do Rio de Janeiro e do Jardim Botânico.

O curso foi aprimorado para atender às demandas do público alvo e também

foi adaptado às versões disponíveis do programa. Dessa forma, esses cursos

têm permitido que funcionários da Embrapa conheçam os princípios de

geoprocessamento e de sistemas de informação geográfica e apliquem esses

conhecimentos em seus trabalhos de pesquisa, desenvolvimento e

transferência de tecnologia.

A apostila foi elaborada com o objetivo de facilitar o acesso aos exercícios

preparados nesses cursos. Sendo composta por exercícios práticos, a

apostila não tem como objetivo a fundamentação teórica, e sim fornecer,

passo a passo, instruções para o uso das principais ferramentas do programa

ArcGIS.



O material para a execução desses exercícios encontra-se disponível na

Intranet da Embrapa Solos, página de documentos do Núcleo de

Geoprocessamento (NGeo).

Maria de Lourdes Mendonça Santos

Chefe Geral da Embrapa Solos
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Introdução

Essa publicação é um roteiro que se destina ao treinamento de pesquisadores,

analistas e estagiários da Embrapa Solos e também de seus parceiros em

ferramentas de Sistemas de Informação Geográfica, no caso, utilizando o

programa ArcGIS da ESRI.

O treinamento em ArcGis iniciou-se em 2006 e foi oferecido nos anos de 2007

e 2010, contando com a participação de funcionários da Embrapa Solos e de

parceiros de outras unidades da Embrapa, como Agrobiologia, Florestas, Meio

Ambiente e Meio Norte, além de pesquisadores, funcionários e estudantes da

Universidade Estadual do Rio de Janeiro e do Jardim Botânico.

O texto não tem como objetivo a fundamentação teórica, sendo composto

por exercícios práticos. O material para sua execução encontra-se disponível

na Intranet da Embrapa Solos, página de documentos do Núcleo de

Geoprocessaemnto (NGeo).
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Exercício 1 - VAMOS COMEÇAR!!! 
 

A. Familiarização com as ferramentas do ArcGIS: ArcCatalog 
 
Objetivos: Neste exercício você aprenderá a reconhecer os ícones do ArcGIS e visualizar dados 

de diferentes formatos. 
 

1. Verifique na barra de iniciar > programas > ArcGIS, que existem dois tipos de 
programas: ArcCatalog e ArcMap . Vamos começar pelo ArcCatalog. 

 
2. Abra o ArcCatalog. 
 
Quando o ArcCatalog abrir, observe a árvore do catálogo do lado esquerdo da janela. A catalog 
tree lista o conteúdo da sua conexão atual. 
 
3. Navegue até a pasta do curso: C:/curso_Arcgis/formatos dados. 

 

 
 
 

4. Nova conexão. Você pode simplificar o processo de navegação por meio da adição de uma 

nova conexão. Clique no botão Connect to Folder , navegue até a pasta 
C:/curso_Arcgis/formatos dados e clique Ok. 

Observe que o caminho para a pasta de dados do curso foi adicionado como uma nova conexão. 
 
De agora em diante, utilize essa nova conexão para explorar os dados do curso. 
 
5. Formatos de dados. Entre na pasta formatos dados e verifique os formatos de dados 

existentes. 
Quais os formatos de dados existentes nessa pasta? 
 
6. Clique sobre o layer atividades poluidoras.shp e utilize a guia preview. Explore a figura 

nas opções geographic e table no rodapé. 
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∼ Dica: Os layers de polígonos, linhas e pontos são dados no formato shape (shp). Esse 
formato de dados envolve vários arquivos. Você pode visualizá-los utilizando o Explorer ou 
verificar na figura a seguir. O dado em formato raster envolve duas pastas, uma com o 
nome do dado e outra info. Por envolver vários arquivos e pastas, para copiar ou excluir 
dados é importante utilizar o ArcCatalog. 

 
 
 

 
 
7. Copie dados de uma pasta a outra no ArcCatalog. Clique sobre atividades poluidoras.shp, 

utilize a tecla copy, vá para a pasta saída e utilize a tecla paste. Agora faça o mesmo para o 
raster rjrem . 

 
8. Ferramentas de visualização. Clique sobre o layer fragmentos.shp na janela preview e 

utilize as ferramentas: 

 
Na ordem, elas representam: mais zoom, menos zoom, mover e extensão total. 
Observe que as ferramentas mais e menos zoom podem fazer zoom ao se clicar em um ponto ou 
ao se fazer um retângulo. 

∼ Dica: Mova o mouse sobre as ferramentas para ver o seu nome. 
 
9. Tumbnails. Para criar thumbnails, adicione um novo folder e selecione o shape 

C:\Curso_Arcgis\Dados Gerais\Brasil\Estados.shp, visualize na barra CONTENTS 
como o dado é apresentado. Agora escolha a barra PREVIEW . Dê um zoom para 

centralizar o mapa e utilize a ferramenta Create Thumbnail . Agora verifique na 
barra CONTENTS como o dado aparece. 

 
10. Metadados: Clique na layer fragmentos.shp na Catalogtree. 
 
Observe a informação que é apresentada nas diferentes opções: Contents, Preview e 
Description. Observe e clique nas diferentes opções disponíveis na barra de ferramentas. 
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B. Familiarização com as ferramentas do ArcGIS: ArcMap 

 
Objetivos: Neste exercício você aprenderá a visualizar dados de diferentes formatos, navegar 

em mapas e consultar atributos de dados geográficos. 
 

1. Abra o ArcMap  . Você observará o diálogo inicial com três opções. Escolha a opção 
“Existing map... Browse for more” >OK.  

 
2. Navegue até o exercício comeco.mxd armazenado em Curso_ArcGIS\Comeco. 
O mapa que você abriu possui, para o Estado do Rio de Janeiro, informação de rodovias, 
hidrografia, municípios (estas últimas duas layers não estão ativas) e regiões. 
Cada uma dessas categorias de informação geográfica denomina-se layer. 
A table of contents faz uma listagem das layers no mapa. Mostra a cor ou símbolo utilizado 
para desenhar cada layer e indica se essa layer está disponível ou não para visualização. 
 
3. Observe como habilitar e desabilitar as layers para visualização na table of contents.  
 
O que é um arquivo.mxd? 
O que é uma layer e que tipo de informação ela armazena? 
 

 
 
4. Deixe visível somente a layer dos municípios (desmarque as restantes layers). Pressione 

agora o botão CTRL  no teclado e habilite uma das layers desabilitadas. Descreva o que 
aconteceu. 

 
5. Mude o nome das layers clicando com o botão direito em cada uma delas, indo a Properties 

e depois na tabulação General. Mude: município para Municípios do RJ; hidrografia  
para Rede Hidrográfica. 

 
6. Deixe visível somente a layer de municípios. Faça um zoom detalhado (retângulo) no 

município do Rio de Janeiro. Se você teve erros na realização do Zoom, clique na 

ferramenta Go Back  para ir no zoom anterior, ou utilize a rolagem do mouse. 
 

7. Clique na ferramenta Select Features  e selecione esse município. Clique com o botão 
direito na layer Municípios do RJ > Open atribute table e observe que somente uma 
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feição se encontra selecionada. No rodapé da tabela, clique na opção show selected 
records. Descreva o que aconteceu. 

 

 
 

8. Mantendo a tabela aberta, mova o cursor Select Features  sobre algum dos 
municípios, clique e descreva o que aconteceu. 

 
9. Agora, deixe todos os municípios visíveis na tabela usando a opção show all records no 

rodapé da tabela. Retire a seleção do município: clique em options > clear selection. 
 

10. Clique agora na ferramenta Identify  e clique em um dos municípios. O diálogo de 
identificação de resultados aparecerá. Observe que você pode escolher o layer para o qual os 
resultados aparecerão. 

∼ Dica: Explore outras opções, por exemplo, alllayers e veja o que acontece. 
 
11. Para observar os nomes de forma permanente no mapa, você pode etiquetar as cidades. Na 

tabela de conteúdo, clique com o botão direito na layer Municípios do RJ > Label 

Features. Observe a janela de visualização. Dê um zoom utilizando a ferramenta . 
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12. Agora você experimentará outras duas ferramentas do ArcView: Magnifier e Overview. 

Pesquise como estas ferramentas funcionam. Estas ferramentas se encontram localizadas no 
menu Window. 

 

 
 

13. Bookmark. Utilize o Zoom in  em uma área de seu interesse no mapa. Você poderá 
guardar esse display como um Bookmark, que poderá ser usado em qualquer outra 
oportunidade. 

Clique no menu Bookmarks > Create e coloque o nome desejado para o Bookmark. 
Experimente as formas de uso de um Bookmark. 
 
14. Atribute tables. Agora você trabalhará com as tabelas de atributos dos seus dados. Na 

tabela de conteúdo clique com o botão direito na layer de Municípios do RJ e clique em 
Open Attribute Table. 

Pesquise os atributos descritos na tabela. 
O campo FID  contém um identificador único para cada registro. 
O campo Shape descreve a geometria das feições. 
Os outros atributos são criados de acordo com o interesse do usuário. 
 
15. Clique com o botão direito no nome do campo FIRST_MUNI > Freeze/UnfreezeColumn. 

Observe os resultados dessa operação. Clique agora no botão table options e observe as 
opções disponíveis. 
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Exercício 2 
Visualização de dados 

 
Objetivos:  Organização de Layers em Data Frames 

Simbolização de Layers e configuração de propriedades 
Geração de Layers 

Etapa 1. Adicionar dados ao ArcMap 

1. Abra o ArcMap com um novo mapa. 

2. Clique no botão Add Data para adicionar novas layers. 

3. Navegue até a pasta Curso_Arcgis\Dados Gerais\Rio_de_Janeiro\Fitoecologico e 
adicione fitoecologico. Navegue até Curso_Arcgis\Dados 
Gerais\Rio_de_Janeiro\regionalizacao e adicione mun&reg . Navegue até 
Curso_Arcgis\Formatos dados e adicione rjrem  em formato raster (grid). 

}Informação: O ArcMap coloca este tipo de dados (raster) no final da Tabela de conteúdo. 
Existe uma configuração inteligente na ordem de desenho das layers. 

 

4. Clique no Data Frame Layers. Clique no Data Frame Layers uma segunda vez. Renomeie 
o Data Frame para Rio de Janeiro. 

5. Clique com o botão direito no Data Frame Rio de Janeiro e clique em Properties. 

6. Clique na guia General e observe que o nome também pode ser mudado a partir do diálogo 
Properties. Clique OK . 

 

7. Mude o nome da layer rjrem  para Fragmentos e mude o nome da layer mun&reg  para 
municípios. 

Etapa 2. Configuração da simbologia das layers 

8. Clique no símbolo da layer municípios para ativar a paleta de cores. Esta é uma das formas 
de mudar a simbologia. 

9. Em Fill color,  clique em No Color. 
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10. Em Outline color, clique em preto e em Outline Width  escolha 2. Clique OK . 

11. Clique no sinal (-) da layer fragmentos e observe. Clique em (+) para observar os 
diferentes valores na legenda. 

12. Clique com o botão da direita na layer fitoecologico e abra o diálogo de Properties > 
Tabulação Simbology, no quadro Show > Categories > Uniquevalues. 

13. Para Valuefield, clique em região_fit. 

14. Clique em Add All Values. 

 

15. Observe que existem alguns retângulos sem nomes dos dados. Clique sobre eles e utilize a 
opção Remove para remover essas representações. 

∼Dica: Para visualizar o esquema de cores por nome, clique com o botão direito em cima do 
gráfico de cores e desabilite a opção Graphic View. 

 

16. Em Color Ramp, desabilite a opção Graphic View e escolha o esquema de cores Pastels e 
clique OK . 

17. ∼Dica: Feche a Table of Contents e abra-a novamente usando o menu Window > Table 
of Contents. 

18. Mude a cor e tamanho dos símbolos da layer municipios para que estes apareçam mais 
notáveis no mapa. 

19. Clique com o botão direito a layer municípios e clique em Label Features. O ArcMap 
coloca o primeiro campo texto (string) da tabela como default para configuração das 
etiquetas (labels). Confira isto abrindo a tabela da layer municipios.  
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∼Dica: Para abrir a tabela, clique com o botão direito na layer > Open Attribute Table. 

20. Salve as mudanças em um documento.mxd com o nome de Rio de Janeiro dentro da sua 
pasta de trabalho: c:\Curso_Arcgis\saida. Usar o comando Save as... 

21. Clique no menu Insert e clique em Data Frame. 

22. Mude o nome do novo Data Frame para Brasil. 

23. Clique no botão Add . 

24. Navegue até a pasta c:\Curso_Arcgis\Dados Gerais\Brasil e adicione Estados, 
Hidrografia  e Rodovias.shp. 

Verifique que somente os dados do data frame ativo podem ser visualizados. 

Etapa 3. Classificação dos dados 
 

25. Ative o data frame Rio de Janeiro clicando com o botão direito sobre ele > Activate. 

26. Adicione usando o botão Add  o layer pib.shp que está em c:\Curso_Arcgis\Dados 
Gerais\Rio_de_Janeiro\regionalização. 

27. Abra o diálogo Properties da layer pib. 

28. Clique na tabulação Simbology. 

29. Clique em Show > Quantities > Graduate Colors. 

30. Para Value field, clique em PIB_TOTAL_ . 

31. Para Number of classes, escreva 5. 

 

32. Clique OK  e observe os resultados no mapa. 
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33. Clique novamente na tabulação Simbology e em Show > Quantities > Graduate Colors. 
Teste outras opções como número de classes e classificação. 

34. Existem 6 métodos de classificação. Vamos explorar cada um deles: 
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Uso de símbolos 

35. Abra o diálogo Properties da layer pib. 

36. Clique na tabulação Simbology. 

37. Clique em Show > Quantities > Graduate Symbols. 

Para Valuefield, clique em PIB_PER_CA. 

Para Number of classes, escreva 5. 

 

 

 

Clique OK  e observe os resultados no mapa. 
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Uso de gráficos 

Abra o diálogo Properties da layerpib. 

Clique na tabulação Simbology. 

Clique em Show > Charts > Bar/Column. 

Para Field Selection, clique em PIB_PER_CA. 

 

 

Clique OK  e observe os resultados no mapa. 

Etapa 4. Criar um arquivo layer 
 

38. Clique com o botão direito na layer pib e logo em Save as layer file. 

39. Salve como grafico_pib.lyr  na pasta Curso_Arcgis\saida. 

40. Salve o mxd . 

41. Clique no botão New Map File  para trabalhar em um novo documento mxd. 

42. Adicione a layer grafico_pib.lyr  que você criou nos passos anteriores. 

43. Observe que a layer será adicionada com a simbologia e a classificação que você salvou 
previamente. 

44. Feche o ArcMap. 



                                                       Apostila do Curso Introdução ao Geoprocessamento Utilizando o ArcGIS   

 

 

21 

 
Exercício 3 

Simbolização de feições e rasters 
 
Objetivos: Simbolização de feições vetor (pontos, linhas e polígonos).  Diferentes formas de 

classificação dos dados geográficos para visualização. 
 

1. Abra ArcMap  e clique na opção que permite trabalhar com um mapa já existente. 
Navegue até Curso_Arcgis\Comeco\. Selecione ex03a.mxd e clique Open. Observe 
detalhadamente as áreas mostradas por ArcMap. Na Tabela de Conteúdo, observe o Data 
frame Aeroportos e as duas layers: aeroport_heliporto e mun&reg . 

 
2. Na Tabela de Conteúdo, clique no botão direito no símbolo da layer mun&reg  para abrir a 

paleta de cores e mude para outra cor de sua preferência. 
 

 
 
3. Na Tabela de Conteúdo, clique no símbolo da layer mun&reg . Nas opções disponíveis, 

clique Outline Color = Gray. 
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4. Na layer aeroport_heliporto, mude o símbolo para circle2, cor de sua escolha e tamanho 
10. 

 
5. Na Tabela de Conteúdo, clique com o botão direito na layer aeroport_heliporto e clique 

Label Features. 
 
6. Na Table of Contents, clique com o botão direito no data Frame Aeroportos e clique 

Properties e depois na tabulação Frame. Em Background, mude a cor de fundo do mapa 
para Light blue, clique OK . Observe o resultado no mapa. 

 

 
 
7. Salve o seu trabalho em Curso_Arcgis\Saida com o nome meu_ex03a.mxd. 
 

8. Abra  o exercício ex03b.mxd que está em Curso_Arcgis\comeco. Você exercitará a 
visualização de atributos qualitativos. 

 
Observe que você está trabalhando no modo Layout View, que permite visualizar uma 
página virtual com o mapa que está sendo preparado para impressão. O mapa tem 3 data 
frames inseridos, sendo que o data frame ativo é o que está tracejado. Para trabalhar com os 
dados, você deve mudar o modo de visualização. No menu principal, clique View > Data 
View. O data frame ativo é o Municipios que aparece em negrito. 
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9. Clique com o botão direito na layer mun&reg  e clique Properties. Clique na tabulação 

simbology. Você deseja neste exercício simbolizar cada município com uma determinada 
cor, portanto deverá usar um atributo que possua um único valor para cada feição tal como o 
Nome. 

 
10. Na caixa Show, clique em Categories > Unique values. 

 

11. Defina Value Field = FIRST_MUNI e no pé do diálogo clique Add All Values. Em Color 
Ramp, clique com o botão direito na lista de cores e clique em Graphic View para 
desabilitar. Escolha a paleta de cores denominada Pastels. Desmarque também <all other 
values> na coluna de símbolos. Clique OK . Observe o mapa na área de visualização. 
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12. Clique com o botão direito na layer mun&reg  e clique em Label Features para adicionar 
nome aos municípios. Feito isto, o mapa de municípios está terminado. Passaremos agora a 
trabalhar no mapa de transportes. 

 

13. Ative o Data Frame Transportes. Para isso, clique com o botão direito no Data Frame 
Transportes > Activate. Clique no sinal (+) à direita de Transportes para visualizar as 
layers que contém. 

 

14. Antes de simbolizar a layer, você visualizará a sua tabela de atributos: clique com o botão 
direito na layer rodovias_rj e depois em Open Attribute Table. Examine os diferentes 
atributos da tabela e feche-a. 

 
15. Clique com o botão direito na layer rodovias_rj para abrir o diálogo de propriedades e 

clique em Symbology. Vá para Categories > Uniquevalues; Value Field = TIPOPAV . 
Clique em Add All Values. Dê um duplo clique na linha que representa as rodovias não 
pavimentadas para abrir o Symbol Selector. Mude o símbolo para “roads, unpaved”. Para 
as rodovias pavimentadas (pista dupla), mude o símbolo para “Highway” e para as 
pavimentadas (pista simples) “Highway Ramp”.  Desmarque <all other values>. Observe 
o resultado na janela de visualização. 
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16. Observe agora o estado do painel que você está preparando para impressão, mudando de 

Data View para Layout View no menu View. 
 
17. Você pode salvar os seus dados em Curso_Arcgis\Saida\meu_ex03b.mxd e 

posteriormente abrir outro map document com o qual você trabalhará. 
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Exercício 4 
Projeção cartográfica dos dados 

 
Objetivos: Projetar os dados e transformar de um sistema de coordenadas a outro. 
 

 
1. Abra o ArcCatalog e adicione o folder c:\Curso Arcgis\Dados 

Gerais\Rio_de_Janeiro\infraestrutura . 
 
2. Verifique o sistema de projeção do shape rios_simples.shp utilizando o botão da direita 

Properties > XY Coodinate System. 
Qual o sistema de coordenadas dos dados? 
 
3. Vamos alterar o sistema de coordenadas dos dados para o Sistema Geográfico. 

4. Abra o Arctoolbox na opção Data Management Tools > Projection and 
Transformation > Feature > Project. 

 

 
 

5. Em Input Dataset or Feature Class, selecione o arquivo rodovias_rj.shp. 
Em Output Dataset or Feature Class, o arquivo será automaticamente repetido. 
Em Output Coordinate System, escolha Select > Geographic Coordinate System > 
South American > South American Datum 1969.prj > Add > Ok. 
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6. Visualize na Catalog tree o novo arquivo criado rodovias_rj_Project.shp e compare seu 
sistema de coordenadas. 
Verifique também as coordenadas dos dados que são mostradas na barra inferior da tela. 
Veja as diferenças entre o dado criado e o rodovias_rj.shp original. 

 
7. Vamos projetar dados que estão em sistema de coordenada geográfica. Primeiro 

conecte o folder c:\Curso Arcgis\Dados Gerais\Rio_de_Janeiro\hidrografia. 
 
8. Verifique o sistema de projeção do shape rios_simples.shp utilizando o botão da direita 

Properties > XY Coordinate System. 
 
Qual o sistema de coordenadas dos dados? 
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9. Abra o Arctoolbox  na opção Data Management Tools > Projection and 
Transformation > Feature > Project. 

 
10. Em Input Dataset or Feature Class, selecione o arquivo rios_simples.shp. 

Em Output Data set or Feature Class, o arquivo será automaticamente repetido. 
Em Output Coordinate System, escolha Import e selecione o arquivo rodovias_rj (que 
sabemos ter a projeção Lambert Conforme Cônica) > Add. 
 
Verifique na janela Details os parâmetros da projeção: 
False Easting: 500000 
False Northing: 7843839,703290 
Central Meridian: -45 
Standard Parallel 1: -20,66666 
Standard Parallel 2: -23,33333 
Latitud of Origin: -19,5 
 
Clique em OK. 

 
11. Visualize, na Catalog tree, o novo arquivo criado e compare seu sistema de coordenadas. 

Verifique também as coordenadas dos dados que são mostradas na barra inferior da tela. 
Veja as diferenças entre o dado criado e o rios_simples.shp original. 
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Exercício 5 
Seleção e Consulta a Dados 

 
Objetivos: Selecionar dados e consultar seus atributos 

 
 

1. Abra em ArcMap  o mapa Curso_Arcgis\comeco\ex05a.mxd. Observe a layer 
sistema eletrico, nela consta a localização das usinas e subestações de energia 
elétrica do Estado do Rio de Janeiro. 

 

2. Use a ferramenta Select Features  e marque um retângulo no mapa. Verifique as 
usinas e subestações selecionadas. 

 
 

 
 

3. Agora altere a seleção. Você quer selecionar as feições da layer municipios, que 
representam os municípios deste local. 

 
Escolha a opção List by selection na Table of Contents, clique com o botão direito em 
municípios e marque a opção Make this the only selectable layer. 
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4. Faça novo retângulo usando a ferramenta Select Features. Veja que agora foram 

marcados somente os municípios. 
 
5. Verifique também as opções de seleção em Selection > Options. 
Verifique como muda a seleção utilizando as três opções disponíveis. 
 

 
 
6. Você ainda pode criar novas seleções a partir de feições previamente selecionadas 

utilizando as opções de Selection > Interactive Selection Method. 



                                                       Apostila do Curso Introdução ao Geoprocessamento Utilizando o ArcGIS   

 

 

31 

 
 

 
 
7. Estatísticas das feições selecionadas. Selecione um conjunto de municípios e use a 

opção Selection > Statistics. Escolha o campo PIB_PER_CA e verifique as 
estatísticas e distribuição. 

 

 
 



                                                       Apostila do Curso Introdução ao Geoprocessamento Utilizando o ArcGIS   

 

 

32 

Exercício 6 
Seleção por atributos 

 
Objetivos: Identificação de feições – Seleção 

Consulta de atributos – Sintaxe SQL 
 

Você precisa identificar todas as subestações de distribuição de energia que são 
particulares no Estado. 

 

1. Abra em ArcMap  o mapa Curso_Arcgis\comeco\ex05a.mxd. Observe a layer sistema 
eletrico, nele consta a localização das usinas e subestações de energia elétrica do Estado do 
Rio de Janeiro, classificados pelo tipo (TIPO ) e ainda pela concessionária responsável 
(CONCESSION). 

 

2. Aplique um Zoom to layer na layer sistema eletrico e clique na ferramenta Identify . 
 
3. Clique em alguns dos símbolos do sistema eletrico e examine a informação apresentada. 

Depois de examinar feche o diálogo. 
 
4. Escolha a opção List By Selection na Table of Contents e deixe sistema elétrico como 

opção de seleção. 
 

5. Na barra de ferramentas, clique na ferramenta Select Features . 
 

No mapa, clique nas usinas ou subestações localizadas no município do Rio de Janeiro. Para 
selecionar mais que uma estação, use a tecla SHIFT . 

 
6. Abra a Attribute Table  da layer sistema elétrico e clique na opção Show selected records 

para observar somente as feições selecionadas. 
 

 
 

7. Retire a seleção dos dados. Primeiramente deixe todos os dados visíveis clicando em Show 
all records. Em seguida clique em options > clear selection. Feche a tabela. 
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8. Agora você realizará uma seleção de feições baseado nos seus atributos. Clique no menu 

Selection > Select by attributes. No diálogo de seleção, coloque sistema elétrico como 
layer de seleção e como método escolha Create new selection. Construa a seguinte 
expressão: “TIPO” = ‘SUBESTAÇÃO’ AND “CONCESSION” = ‘PARTICULA R’. 
Clique em Ok. 

 

 
 

Observe no mapa as feições selecionadas: todas as subestações particulares. 
Você pode também salvar a sua expressão de consulta para que possa ser usada em outra 
oportunidade. 
 
9. Posteriormente, no diálogo Select by Attributes, clique clear para remover a consulta e 

clique Close. 
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Exercício 7 
Seleção por localização 

 
Objetivos:     Diálogos para seleção por localização 

Diferentes opções para consulta  
 

Você agora selecionará os municípios que contêm as subestações particulares selecionadas no 
exercício anterior. 

 
1. No diálogo Select by location: 

� Clique select features from; 
� Marque na caixa target layer(s): municipios; 
� Na caixa “spatial selection method for target layer(s) features”, marque 

“intersect the source layer feature”. 
� Em source layer: sistema elétrico; 
� Clique Apply . 

 
 
Observe o resultado no mapa. Agora abra a tabela de atributos da layer municipios. 
Visualize somente os municípios selecionados, clicando em show selected records. Coloque 
em ordem alfabética clicando na parte superior da coluna MUNICÍPIOS  com o botão da 
direita sort ascending. Quantos municípios foram selecionados? 

 

 DESAFIO**: 
 
1. Abra o exercício ex_UCPI.mxd que está armazenado em Curso_Arcgis\comeco. Observe 

a informação apresentada: unidades de conservação de proteção integral 
(uc_protecaointegral_Lambert) e (CEPF_fragmentos). 

 
2. Você precisa localizar todos os fragmentos que estão a uma distância máxima de 1000 

metros do Parque Estadual dos Três Picos.  

∼Dica: Selecione inicialmente o Parque Estadual dos Três Picos. Em seguida, utilize 
Selectbylocation. 
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Exercício 8 

 
Entrada de Dados Tabulares e Edição de Dados na Tabela de Atributos 

 
Objetivos: Utilizar as ferramentas de Join e Relates e fazer a edição na tabela de atributos. 
 
1. Abra o exercício ex08.mxd que se encontra em Curso_Arcgis\comeco. 
Observe que, ao alterar para List by source no alto da Table of Contents, o dado referente à 
tabela pib.dbf é apresentado. Esse dado não está espacializado, é apenas uma tabela. 
 

 
 
2. Explore o dado, abra a tabela e verifique suas propriedades. 
Clique com o botão da direita do mouse na coluna de PIB_TOTAL_ e utilize as opções de Sort, 
Statistics, Freeze/UnfreezeColumn. 
 
3. Utilize a opção Summarize para salvar um arquivo com as estatísticas selecionadas dos 

campos de interesse. Salve em C:\Curso_Arcgis\Saida e veja os resultados. 
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4. Relate.  
Objetivo: fazer consulta sobre PIB de municípios selecionados observando diretamente 
nas tabelas. 
 
5. Clique com o botão da direita no shape mun&reg  e escolha Join and Relates > 

Relate. 

 
 

 
6. Selecione as opções como na figura a seguir e clique em Ok. 
É importante que exista um campo comum para fazer a relação entre as tabelas. Neste 
caso, o COD_IBGE é o identificador dos municípios, que são as variáveis comuns a 
ambos os dados (mun&reg e pib). 
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7. Agora abra a tabela de atributos do shape mun&reg  e selecione alguns municípios. 
 
8. Use o botão Table Options e selecione em Related Tables o nome da relação estabelecida 

– Relate1. Verifique o que ocorre. 
 

 
 

9. Remova a seleção dos dados: Selection > Clear Selected Features. 
 
10. Remova a relação entre tabelas: Clique com o botão da direita em mun&reg , join and 

relates > Remove relates e selecione Relate1. 
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11. Join.  
Objetivo: visualizar em uma mesma tabela dados de outra tabela. 
 
12. Clique com o botão da direita no shape mun&reg  e escolha Join and Relates > 

Join. 
 
13. Selecione as opções como na figura a seguir e clique em Ok. 
É importante que exista um campo comum para fazer a relação entre as tabelas. Neste 
caso, o COD_IBGE é o identificador dos municípios, que são as variáveis comuns a 
ambos os dados (mun&reg e pib). 
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14. Agora abra a tabela de atributos do shape mun&reg  e verifique se os dados da tabela pib 

foram adicionados. 
 
15. Utilizando a seleção de atributos, verifique quais municípios tem PIB per capta maior que 

12000. Forme a seguinte expressão: "pib.PIB_PER_CA" >12000 
 

 
16. Remova a relação entre tabelas: Clique com o botão da direita em mun&reg , join and 

relates > Remove join e selecione pib. 
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Exercício 9A 

 
Entrada e edição de dados vetoriais 

 
Objetivo: Criar arquivo de pontos a partir de uma planilha. 
 
1. Abra a tabela capitais_estaduais_Brasil.xls que se encontra em C:\Curso_Arcgis\Dados 

Gerais\Brasil. 
Observe as informações presentes na tabela. As coordenadas fornecidas referem-se à localização 
das sedes das capitais estaduais. 
 

 
 
Podemos vizualizar as sedes das capitais estaduais no ArcGis no formato vetorial de ponto. Para 
tal, é necessário transformar as coordenadas de graus, minutos e segundos em graus decimais, 
utilizando as equações: 
 

 
Para os hemisférios Norte e Leste 
 

 
Para os hemisférios Sul e Oeste 
 
Abaixo é dado um exemplo de sintaxe para aplicação da segunda equaçãono Excel: 
 
= (I2+(J2/60)+(K2/3600))*-1 
 
2. Aplique a fórmula no Excel para as latitudes e longitudes em Fórmulas > Inserir Função. 
 

}Importante: As coordenadas X referem-se às longitudes e as Y às latitudes. 
 
3. Após obter os resultados de latitudes e longitudes para todas as linhas, salve e feche o 

arquivo. 
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4. Abra o ArcMap e adicione o arquivo Excel capitais_estaduais_Brasil.xls em Add Data , 
já modificado que se encontra em C:\Curso_Arcgis\Dados Gerais\Brasil. 
 

 
5. Clique com o botão direito do mouse em Capitais$ e clique na opção Display XY 

Data. 
 

 
 
6. Na janela Display XY Data, selecione o nome da tabela e defina as colunas que contêm os 

dados de X e Y.  
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7. Clique no botão Edit para selecionar o sistema de coordenadas segundo a figura a seguir. 

Ao finalizar clique no botão OK . 

 
 
Observe que foi criado um arquivo temporário (Capitais$Events) de pontos com a localização 
das sedes das capitais estaduais. 
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8. Salve o arquivo temporário como um arquivo no formato shape. Clique com o botão direito 
do mouse no arquivo temporário criado e selecione: Data > Export Data... 
Salve em C:\Curso_Arcgis\Saida com o nome sedes_capitais_estaduais e em Save as 
type: shapefile. 

 

 
 
9. Adicione o shape com os limites estaduais (Estados.shp), encontrado em 

C:\Curso_Arcgis\Dados Gerais\Brasil e visualize o resultado. 
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Exercício 9B 

 
Entrada e edição de dados vetoriais 

 
Objetivos: Executar procedimentos básicos de edição de vetores 
 
1. Abra o exercício ex09b.mxd que se encontra em C:\Curso_Arcgis\comeco. 
Observe que é fornecida uma imagem do sensor TM Landsat-5, composição 5 (R), 4 (G), 3 (B), 
na qual a vegetação aparece na cor verde. Também é fornecido o limite da área que utilizaremos 
como teste do exercício de edição. 
 

 
 
2. Crie um arquivo formato shape no ArcCatalog. Para tal, abra o programa ArcCatalog, vá na 

pasta C:\Curso_Arcgis\Saida, clique com o botão direito e selecione: New > Shapefile e 
complete os dados da janela conforme figura a seguir. Em Description, clique em Edit > 
Select > Projected Coordinate Systems > UTM > South America > South American 
1969 UTM Zone 23S.prj e ADD. 
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3. Adicione o shape criado (uso_da_terra) no ex09b.mxd em Add Data. 
 
4. Abra a tabela de atributos do uso_da_terra e adicione um novo campo de atributo 

selecionando: Options > Add Field. 
Complete os campos da janela Add Field com os dados da figura a seguir. 
 

 
 
5. Início da edição. Na barra de menu, selecione Customize > Toolbars e marque a opção 

Editor, ou apenas clique com o botão direito do mouse na barra de menu. 
Na barra de edição, clique em Editor > Start Editing  e marque uso_da_terra. 
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6. Para criar um polígono, automaticamente uma guia “Create New Features” irá abrir no 

canto direito com a layer uso_da_terra, clique nela. 
 

 
Abaixo, há uma guia Contruction Tools. Clique na opção Freehand. 
Inicialmente trace os limites de uma área de água. A cor da layer uso_da_água pode ser 
alterada para “no color”,  facilitando a visualização no polígono. 
Ao finalizar, abra a tabela de atributos e inclua na coluna classe o atributo correspondente, neste 
caso, agua. 
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7. Para alterar o formato do polígono criado: 
 
Selecione o polígono criado através da ferramenta Select Features; em seguida clique em Edit 
Vertices na barra Editor e faça as alterações necessárias movendo os vértices do polígono. 
Observação: Neste caso, mantenha o ícone no meio da frase. 

 

 
 
 
8. Para fazer um novo polígono adjacente a um já existente: 

Selecione o polígono criado utilizando o botão Select Feature . Selecione Auto-Complete 
Polygon na Contruction Tools. Para iniciar um novo polígono e forma que fique adjacente ao 
marcado, o primeiro e o último vértices deverão estar localizados na parte interna do polígono já 
existente. 
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Inclua na Tabela de atributos a classe a que pertence o novo polígono, no exemplo, área urbana. 
 

 
 
9. Para dividir um polígono em duas partes: 

Selecione o polígono a ser dividido e, a seguir, a opção Cut Polygon Tool . Trace uma linha 
no local onde deverá ocorrer a divisão. 
Na tabela de atributos, denomine como agricultura a classe do novo polígono criado. 
 
 

 
 
 
 
 
 
10. Para agrupar dois polígonos transformando-os em um único: 
Selecione os dois polígonos a serem agrupados e, na barra de edição, selecione: Editor > 
Union. 
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Exercício 10 

 
Geração de mapas para apresentação 

 
Objetivos: Layout View vs. Data View; Adição de elementos no mapa; Configuração de página 

e impressão final. 
 

1. Abra o documento Curso_Arcgis\Comeco\ex10.mxd em ArcMap. Esse documento possui 
três Data Frames: 

 
-  Layers (UC de Proteção Integral); 
-  New Data Frame (UC de Uso Sustentável) e 
-  New Data Frame 2 (Unidades de Conservação). 

 
Mude o nome dos Data Frames para os sugeridos entre parênteses. Esses dois Data Frames 
farão parte do seu mapa. Você exibirá o Estado do Rio de Janeiro nas três situações: mostrando 
a localização das UCs de Proteção Integral, das de Uso Sustentável e de ambas reunidas. 
 
2. Clique o menu View e clique em Layout View. Observe que os Data Frames são 

empilhados na página virtual de acordo com o seu ordenamento na tabela de conteúdo. 
 

3. Na barra de ferramentas Layout, clique no botão Zoom In . 
 
4. Clique no menu em File > Page and print Setup e marque a opção Landscape para mudar 

a orientação do seu mapa. 
 
5. Agora você alinhará os Data Frames na página virtual. Redimensione e posicione os Data 

Frames de acordo com a figura: 
 

 
 
6. Deixe todos os dados na mesma escala (1:5000000) utilizando a barra de escala para fixá-la.  
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7. Verifique que o Data Frame UC Uso Sustentável está deslocado do centro do retângulo. 

Para mudar sua posição, use a ferramenta. 
 

8. Verifique que as ferramentas alteram 
os dados no layout, por exemplo, o zoom muda a escala do dado. 

 
 

As ferramentas  não alteram o dado, 
atuam sobre o layout, por exemplo, o zoom não altera a escala do dado, apenas aproxima todo o 
layout para uma visualização mais detalhada. 
 
9. Os Data Frame possuem agora os seus tamanhos e posições finais. Uma outra forma de 

redimensionar os Data Frames é com a tabulação Size and Position no diálogo de 
propriedades do Data Frame. Este diálogo permite configurar a altura e largura do Data 
Frame e a sua posição dentro da página virtual. 

 
10. Adicione um título ao seu Mapa: clique no menu Insert > Title . Uma caixa de texto é 

adicionada à página; coloque nessa caixa o título “Unidades de Conservação do Rio de 
Janeiro” e pressione Enter. Para mudar o título, pode clicar duas vezes sobre ele. Observe 
que o título é pequeno. Você pode mudar o tamanho e outras propriedades clicando na 
opção Draw: clique com o botão direito na barra de menu e marque essa opção. Mude o 
título de acordo com as suas preferências. 

 
11. Identifique cada figura usando caixa de texto. Mude o tamanho da letra para Fonte: Arial , 

Size: 16. Clique agora com o botão direito Rotate or Flip > Rotate left. Siga o modelo a 
seguir. 

 

 
 
12. Adição de Norte. Clique no menu Insert > North Arrow > Esri North 3. Organize o 

símbolo do Norte de acordo com a sua preferência. 
 
13.  Adicionar Escala. Clique em Insert > Scale Bar > Alternating Scale Bar 1 e clique OK . 

Clique com o botão direito na escala para abrir o diálogo Properties. 
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14. Clique com o botão direito na barra da escala > Properties > Scale and units. Observe 
que a escala possui 4 divisões e a divisão da esquerda está subdividido em mais 4 
intervalos. Clique em When resizing... e escolha Adjust width  (ajustar a largura). Isto faz 
com que a largura da barra de escala mude no caso que a escala do Data Frame mudar. 

 
15. A unidade da escala é o metro. Altere Division Units para kilometers (quilômetros). 
 
16. Na caixa Division Value, coloque o valor 100 (quantidade de quilômetros, representada por 

cada divisão de escala). Coloque como número de divisões 3 e número de subdivisões 2. 
Marque a caixa Show one division before zero. 

 
17. Escreva em Label: quilômetros 
 

 
 
 
18. Coloque a barra da escala na parte inferior direita do layout. 
 
19. Clique no Data Frame UC Proteção Integral, clique no menu Insert > Legend para abrir o 

diálogo que ajudará à construção da legenda. Por “default”, a legenda incluirá todas as 
layers que estão inseridas no Data Frame, e o número de colunas da legenda está 
configurado para 1. Clique em avançar para aceitar as configurações. 

 
20. No segundo painel você muda o título da legenda. Como o nome foi incluído ao lado de 

cada Data Frame, apague o nome da legenda. 
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21. No terceiro painel, você adiciona uma borda à legenda. Clique na caixa Border e configure 
para no border. Clique em Background e escolha none. Clique em Preview para pré-
visualizar as configurações que você fez na legenda até o momento. Clique em concluir. 
Para modificar as propriedades da legenda em qualquer momento, você deve clicar com o 
botão direito > Properties. 

 
22. Crie da mesma forma legenda para os demais Data Frames. Para não repetir a informação 

mun&reg, retire das próximas legendas. Posicione as legendas para unificá-las. 
 
23. Verifique que os nomes das classes confundem os usuários. Altere os nomes das layers e 

verá que a legenda também será alterada. 
 
24. Arraste a legenda de acordo com as suas preferências. 
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25. Inserir as coordenadas do mapa. Clique no primeiro Data Frame e selecione com o botão da 

direita Properties > Grids > New Grid. 
Na primeria página, escolha Graticule. 
Na segunda página, Tick marks and labels e intervalos de 1 grau. 
Na terceira página, altere somente text style para Arial 5 . 
Na quarta página, Finish. 
Volte em Properties do Grid e na barra Labels selecione Right e Bottom. 
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