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Procedimento 
Operacional Padronizado 
para Quantificação e 
Mensuração de Areias Via 
Análise de Imagens

Introdução

Os procedimentos usuais de física de solos para 
análises de rotina de areias limitam-se à sua 
quantificação por gravimetria, após separação 
por peneiramento, na análise granulométrica. O 
aprofundamento do conhecimento das areias, 
no entanto, seja para fins de interpretação em 
questões de gênese e classificação de solos 
e sedimentos, seja como ferramenta auxiliar 
para determinação do comportamento físico 
e geotécnico, depende da disponibilidade de 
procedimentos rápidos e com implementação 
simples na análise de rotina. 

A análise de imagens permite a obtenção de 
variáveis morfológicas que podem auxiliar a 
identificação de grãos individuais de areia e 
de parâmetros auxiliares para interpretação do 
comportamento físico destas. A natureza da 
informação obtida a partir das medidas efetuadas 
depende dos objetivos gerais do trabalho, dos 
modelos assumidos e dos algoritmos disponíveis 

no programa. A análise pode ser feita a partir de 
imagens digitais obtidas por meio de câmeras 
acopladas a microscópios, lupas ou eventualmente 
scanners de mesa. Estas imagens são, então, 
processadas por meio de programas adequados 
e quantificadas com base em parâmetros 
morfológicos descritos na literatura. Dentre os 
programas disponíveis para o tratamento e a 
quantificação digital, destaca-se o ImageJ 1.47t 
(FERREIRA; RASBAND, 2012), que, dentre outras 
características, tem tido já ampla utilização 
científica e é disponível sem custo. Permite 
também o desenvolvimento de rotinas específicas 
para outras medidas (pluggins) a critério do 
pesquisador.

O objetivo deste trabalho é apresentar os passos 
e os resultados do teste de um método para a 
quantificação de imagens digitais de amostras 
de areias, baseado no uso de imagens digitais 
microscópicas processadas no programa ImageJ 
(2015).
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Método

Foi utilizada como teste uma amostra de areia 
de um Latossolo Vermelho Amarelo, oriunda da 
região de Luiz Eduardo Magalhães, Bahia, na 
profundidade de 0 a 20 cm. As areias, oriundas da 
análise granulométrica (Tabela 1), foram separadas 
por peneiramento e foi utilizada a fração média 
(0,50 a 0,25 mm). Para a análise das variáveis 
morfológicas, foi utilizado o software ImageJ 1.47t 
(FERREIRA; RASBAND, 2012), seguindo a descrição 
sucinta do método, em três etapas.

Tabela 1. Análise granulométrica da amostra testada. 
Resultados em %. 

Identificação Areia 
Grossa

Areia 
Fina Silte Argila

Amostra 43 48 28 2 22

A. Obtenção e preparo da amostra
As amostras devem ser selecionadas e preparadas 
conforme os objetivos do trabalho. Amostras de 
areias geralmente são provenientes da análise 
granulométrica, podendo ser fracionadas em 
várias peneiras. O procedimento também pode, 
em princípio, ser aplicado a agregados de solo 
estáveis (após secagem) ou sedimentos. Quanto 
mais homogêneo o material (em termos de 
tamanho), melhores as condições para a tomada 
das imagens. Materiais com grande diferença de 
tamanho médio de grãos (mais de uma ordem 
de grandeza) são difíceis de serem analisados na 
mesma imagem, devido a problemas de resolução 
insuficiente dos grãos menores ou de obtenção 
de foco adequado. Recomenda-se, neste caso, a 
separação das frações em tamanhos padronizados 
e sua análise separada.

B. Obtenção das imagens
A tomada de imagens é a parte mais crítica do 
processo, definindo a qualidade final do resultado. 
O equipamento é escolhido em função da natureza 
e dimensão geral dos objetos, e da necessidade 
de magnificação. O ajuste das condições gerais 
do microscópio, da lupa ou do equipamento de 
aquisição de imagens deve ser efetuado antes 
das tomadas de imagens, em testes prévios. A 
resolução da câmera deve ser a melhor possível, 
compatível com as análises posteriores. Caso 
disponível no equipamento, a imagem deve ser 
salva em um formato não comprimido, tipo bitmap 

(BMP) ou TIFF. As imagens devem ser tomadas em 
um fundo contrastante com a cor do material, de 
forma a proporcionar a melhor diferenciação entre 
seu perfil e o fundo. Normalmente um fundo azul 
fosco liso, como o de recipientes de polietileno, 
fornece um bom contraste. A imagem da lâmina 
de referência (padrão para calibração) deve ser 
obtida em condições idênticas às das imagens 
para as quais esta vai servir. A fonte de luz deve 
ser adequada de modo a fornecer iluminação 
suficiente, mas difusa, projetando o mínimo de 
sombra possível, em um ângulo que minimize 
também o brilho dos cristais eventualmente 
presentes. Pequenos ajustes de foco devem 
ser feitos com base na imagem visualizada 
diretamente na câmera, caso esta tenha visor 
independente, ou no monitor, caso seja usado 
um programa de captura de imagens acoplado ao 
equipamento.

C. Tratamento e quantificação digital 
das imagens
As imagens obtidas são processadas e 
quantificadas conforme os procedimentos 
descritos adiante. As imagens originais 
(normalmente coloridas) devem ser convertidas em 
formato binário (preto e branco, 8 bits), para terem 
suas feições identificadas e quantificadas pelo 
algoritmo do programa. Este passo é fundamental 
para a correta identificação dos objetos medidos, 
e se constitui em um dos pontos chave para o 
sucesso da técnica. Constitui-se, também, no passo 
mais complexo, uma vez que a identificação exata 
dos limites dos objetos na imagem não pode ser 
feita de forma totalmente automática, em virtude 
das variações sutis inerentes a cada imagem e 
a transição geralmente difusa entre a borda do 
objeto e o fundo, quando observado em detalhe. 
Cada objeto medido geralmente tem cor e brilho 
próprio, e adequar um procedimento geral para 
toda a imagem constitui-se na maior dificuldade 
operacional da técnica. A seguir, são descritos dois 
procedimentos em detalhes, visando a conversão 
para formato binário (“binarização”) das imagens 
das areias, e sua posterior quantificação. Os 
passos indicados são identificados conforme as 
“janelas” abertas pelo programa, em sequência. 
O procedimento pelo filtro de limiar é mais rápido 
e expedito. O segundo, via filtro de variância, é 
mais trabalhoso e menos prático, mas pode ser útil 
quando há dificuldade de se separar claramente 
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os contornos dos objetos, por exemplo, quando 
os mesmos são semitransparentes e não são 
bem contrastados com o fundo. Isso exige testes 
e comparação com a imagem original, como 
referência.

a) Procedimento com binarização via filtro de limiar 

(*Threshold*):

a1) Abrir a imagem em formato *.jpg (caso o arquivo 

original não esteja em formato TIFF):

File> open

a2) Converter para *.tif e salvá-la no diretório de 

trabalho:

File>save as>tiff

a3) Calibrar a imagem a ser medida:

Abrir imagem de referência (lâmina graduada), já 

previamente tratada.

No console do ImageJ, clicar na ferramenta de desenho 

de linha reta (*Straight*).  

Clicar no ponto de início da referência da imagem e 

arrastar, mantendo o mouse clicado, até o ponto final, 

soltando-o em seguida.

Analyse>Set scale

Digitar a distância conhecida (“Known distance”).

Digitar a unidade de medida (“Unit of lenght”, mm, µm, 

etc.).

Marcar a caixa “Global” e dar ok.

a4) Duplicar a imagem a ser medida (os demais 

tratamentos se aplicam a esta cópia):

Image>duplicate

a5) Aplicar o filtro de mediana:

Process>filters>median

Usar o valor de raio de 3 pixels.

a6) Aplicar a correção “Gamma”:

Process>Math>Gamma

Ajustar o valor de acordo com a imagem.

a7) Aplicar o filtro de limiar (*Threshold*):

Image>Adjust>Color threshold

Ajustar valores na escala RGB de acordo com a imagem. 

Usar o fundo BW.

a8) Caso necessário, inverter a imagem (fundo branco e 

objetos pretos):

Edit>Invert

a9) Preencher buracos:

Process>Binary>Fill holes

Caso necessário*, completar o perímetro das formas que 

não foram preenchidas:

Usar a ferramenta pincel no console (“Paint brush”).

Repetir etapa anterior (Fill holes).

a10) Proceder à análise:

Analyse>Analyse particles

Digitar área mínima de medida (depende do tamanho 

dos objetos a serem medidos na imagem).

Marcar campo de excluir imagens nas bordas (“Exclude 

edges”).

a11) Salvar os resultados:

Na nova janela “Results”, clicar em:

File>Save as

Definir o diretório e o nome do arquivo e salvar.

*A critério do analista, esse passo pode ser dispensado 

(neste caso, os objetos incompletos devem ser 

descartados nas análises posteriores dos dados). 

Recomenda-se seu uso apenas quando existe segurança 

quanto ao traçado do perímetro, verificado na imagem 

original, e os espaços para se completar o perímetro 

sejam menores que 20 pixels. 

b) Procedimento com binarização via filtro de variância 

(*Variance*):

b1)  Abrir a imagem *.jpg (caso o arquivo original não 

esteja em formato TIFF):

File> Open

b2) Converter para *.tif e salvá-la no diretório de 

trabalho:

File>Save as>Tiff

b3) Calibrar a imagem a ser medida:
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Digitar área mínima de medida (depende do tamanho 

dos objetos a serem medidos na imagem).

Marcar campo de excluir imagens nas bordas (“Exclude 

edges”).

b10) Salvar os resultados:

Na nova janela “Results”, clicar em:

File>save as 

Definir o diretório e o nome do arquivo e salvar.

*A critério do analista, esse passo pode ser dispensado 

(neste caso, os objetos incompletos devem ser 

descartados nas análises posteriores dos dados). 

Recomenda-se seu uso apenas quando existe segurança 

quanto ao traçado do perímetro, verificado na imagem 

original, e os espaços para se completar o perímetro 

sejam menores que 20 pixels. 

D. Atributos morfométricos utilizados 
na análise:
Seguem-se os atributos morfométricos 
mais usualmente utilizados em trabalhos de 
morfometria. Outros podem ser gerados, seja pela 
determinação de outras medidas (por meio de 
pluggins) ou por novas combinações dos dados 
brutos gerados nas medições.

Área: é o número de pixels do polígono. Se a 
imagem for calibrada, então a área será computada 
na unidade de calibração; caso contrário será em 
pixels.

Perímetro: é o comprimento do lado externo 
do objeto. Se a imagem for calibrada, então 
o perímetro será computado na unidade de 
calibração; caso contrário será em pixels.

Arredondamento: seu resultado situa-se entre 
0 e 1. É também conhecido como circularidade 
ou angularidade, quanto maior o valor, mais 
arredondado é o objeto. Se o valor é 1, o objeto é 
um círculo perfeito. É calculado pela expressão: 

Ar = 4πA
P2

Onde:

Ar = arredondamento (adimensional).

A = área do objeto (em pixels).

P = perímetro do objeto (em pixels). 

Abrir imagem de referência (lâmina graduada), já 

previamente tratada.

No console do ImageJ, clicar na ferramenta de desenho 

de linha reta (*Straight*).  

Clicar no ponto de início da referência da imagem e 

arrastar, mantendo o mouse clicado, até o ponto final, 

soltando em seguida.

Analyse>Set scale

Digitar a distância conhecida (“Known distance”).

Digitar a unidade de medida (“Unit of lenght”, mm, µm, 

etc.).

Marcar a caixa “Global” e dar ok.

b4) Duplicar a imagem a ser medida (os demais 

tratamentos se aplicam a esta cópia):

Image>Duplicate

b5) Aplicar o filtro de mediana:

Process>Filters>Median

Usar o valor de raio de 3 pixels.

b6) Aplicar a correção Gamma:

Process>Math>Gamma

Ajustar o valor de acordo com a imagem.

b7) Aplicar o filtro de variância:

Process>Filters>Variance

Usar valor de raio de 3 pixels.

b8) Converter em imagem binária, linearizar e preencher:

Process>Binary>Convert to mask

Process>Binary>Fill holes

Caso necessário*, completar o perímetro das formas 
que não foram preenchidas:

Usar a ferramenta pincel no console (“Paint brush”).

Repetir etapa anterior (Fill holes).

Aplicar filtro de erosão (duas vezes consecutivas):

Process>Binary>Erode

b9) Proceder à análise:

Analyse>Analyse particles
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Maior Eixo: é o comprimento da maior linha, em pixels, 
que pode ser traçada através do objeto (Figura 1).

Menor Eixo: é o comprimento da menor linha, em 
pixels, que pode ser traçada através da perpendicular 
ao maior eixo do objeto (Figura 1).

Figura 1. Esquema representativo 
do maior e menor eixo.

Alongamento: é o quociente entre o menor eixo e o 
maior eixo. O resultado é um valor entre 0 e 1. Se o 
valor for igual a 1, o objeto é aproximadamente circular 
ou quadrado. À medida que o valor do alongamento 
se afasta de 1, o objeto torna-se mais alongado. É 
calculado pela expressão: 

AI
 = 

Me
Ma

Onde:

Al = Alongamento (adimensional).

Me = menor eixo (em pixels).

Ma = maior eixo (em pixels).

Compacidade: fornece a medida da circularidade 
do objeto. Seu valor se situa entre 0 e 1. Se o valor 
for igual a 1, o objeto é aproximadamente circular. À 
medida que o valor se afasta de 1, o objeto torna-se 
menos circular. É obtida pela expressão:

Onde:

Co = compacidade (adimensional).

A  = área (em pixels).

Ma = maior eixo (em pixels).

Resultados

A amostra de areia escolhida foi fotografada em 
lupa binocular e foram obtidas cinco imagens para 
cada amostra, das quais foi escolhida aquela mais 
representativa (Figura 2a). Essa imagem foi então 
processada no software ImageJ (Figura 2b) e 
quantificada, gerando uma tabela com os resultados 
dos atributos área, perímetro, compacidade, maior 
eixo, menor eixo, arredondamento, solidez, diâmetro 
de Feret, alongamento, entre outros.

Figura 2. (a) Imagem 
obtida por microscópio 
óptico com aumento 
de 2,5x10x + zoom de 
2.0. (b) Imagem binária 
após a manipulação no 
software ImageJ.

Após a obtenção da imagem binária, procedeu-
se a uma sequência de passos para a obtenção 
dos resultados de atributos dos grãos de areia. 
Abriu-se a imagem binária (Figura 3a) e foram 
selecionadas todas as opções (Figura 3b). Na etapa 
do procedimento de análise de partículas (Analyse 
particles), cada objeto (partícula de areia) recebeu 
um número de identificação (Figura 3c). Ao final, 
foi obtida uma planilha com os atributos medidos 
e assinalados a cada objeto. A Figura 3d mostra 
uma coluna com todos os objetos medidos e, a 
partir do menu ao lado, pode-se trabalhar objeto a 
objeto, se necessário. Por exemplo, se algum dos 
objetos não for de interesse, seleciona-se a linha 
a ser apagada e, no menu “delete”, exclui-se a 
mesma. Para melhor visualização, a tabela exposta 
na Figura 3e mostra os atributos do objeto número 
16. Por fim, salvou-se a planilha em formato Excel 
(Figura 3f). A tabela gerada (Figura 3g) contém os 
valores dos atributos morfométricos, que deverão 
ser utilizados para as análises dos grãos de areia.

(a)

(b)
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Figura 3. Sequência dos passos a serem seguidos para geração dos atributos morfométricos dos grãos de areia.

(e)

(f)

(g)
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Com a tabela de atributos, o usuário pode fazer a 
análise estatística dos dados, checando como cada 
amostra se diferencia quanto ao arredondamento, 
alongamento, solidez, compacidade e outros 
atributos que forem de interesse. Vale salientar que 
o programa ImageJ é um programa aberto que, 
além dos pluggins nativos, permite agregação de 
novos pluggins pelos desenvolvedores e usuários. 
Na Figura 4, podem ser vistos os gráficos da 
distribuição de frequência dos valores de três 
dos atributos de forma da imagem medida, com 
base nos resultados de 41 grãos. Estes resultados 
podem ser usados para a caracterização de 

amostras representativas de areias e para a 
comparação entre diferentes amostras. A título de 
exemplo, e para ilustrar o comportamento destes 
atributos, os resultados individuais de três grãos 
da imagem analisada são apresentados (Figura 
5). Estes representam três morfologias distintas 
(Figura 6), sendo um grão mais arredondado 
(24), um de projeção mais triangular (12) e um de 
conformação mais alongada (17). Uma análise 
por inspeção desses gráficos aponta o diferente 
comportamento de cada grão e possibilita a 
separação dos mesmos em grupos distintos, com 
base em análises estatísticas posteriores. 

Figura 4. Gráficos da distribuição de frequência dos valores de 
três dos atributos de forma da imagem medida.

Figura 5. Resultados individuais de análise de três grãos para 
os atributos (AR) arredondamento (round) e compacidade 
(solidity).
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Figura 6. Morfologia dos três grãos da imagem analisada discutidos.

CONCLUSÃO

O procedimento aqui descrito permite uma análise 
rápida e padronizada de atributos morfológicos de 
grãos de areia e materiais de solo similares a partir 
de imagens obtidas em equipamento convencional 
de microscopia, permitindo a obtenção destes 
para sua análise quantitativa posterior de forma 
sistemática.
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